PSTN dial-in and dial-out issues
Incident Report for CaféX Meetings
Resolved
This incident has been resolved.
Posted 22 days ago. May 29, 2019 - 11:38 UTC
Update
The dial in and out service has now been restored
Posted 22 days ago. May 29, 2019 - 11:37 UTC
Identified
We have identified an issue with dial-in and dial-out not working, we are currently working on it.
Posted 22 days ago. May 29, 2019 - 10:32 UTC
This incident affected: PSTN Dial in.